Service Disruption
Incident Report for Snappy Gifts
Resolved
This incident has been resolved and access to the dashboard has been restored.
Posted Nov 09, 2022 - 13:08 UTC
Investigating
We are currently experiencing a service disruption and our engineering team is working to identify the root cause and implement a solution.
Posted Nov 09, 2022 - 09:05 UTC
This incident affected: Dashboard.